Ticketing System - Intercom Experiencing issues

Incident Report for Lunchbox

Resolved

This incident has been resolved. https://www.finstatus.com/us-hosting
Posted Aug 03, 2026 - 16:19 EDT

Investigating

We are experiencing issues with our 3rd party ticketing software Intercom:

Please refer to this page for status updates:
https://www.intercomstatus.com/us-hosting
Posted Aug 03, 2026 - 10:32 EDT
This incident affected: Customer Support Tools (Customer Support Tools).