Square (POS) Service Disruption

Incident Report for Lunchbox

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 11:48 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 22, 2026 - 11:31 EDT

Investigating

Square POS is experiencing a disruption with their services - we are monitoring. The Square ENG team is on this per their status page:

https://www.issquareup.com/united-states
Posted Jun 22, 2026 - 11:00 EDT
This incident affected: Square (Square POS).