Help Desk Outage

Incident Report for Lunchbox

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 16:15 EST

Identified

There are technical difficulties, and our agents cannot access support tickets at the moment/intermittently.

We will post additional updates on this page.
Posted Jan 09, 2026 - 15:45 EST
This incident affected: Customer Support Tools (Customer Support Tools).